Главная » Файлы » Справка на Примерах 1С » Таблица Значений

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Печать таблицы значений на 1С 8
2012 Май 23, 20:27
Процедура ТЗПечать(ТЗ,Заголовок="") Экспорт
 Перем Таб, Кол,Стр;
#Если Клиент Тогда
 Линия = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная,1);
 ТолстаяЛиния = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 2);
 Таб=Новый ТабличныйДокумент;
 Таб.Область(1,1).Текст=Заголовок;
 Таб.Область(1,1).ШиринаКолонки = 4;
 Таб.Область(1,1).Обвести(ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния);
 Для Кол=1 По ТЗ.Колонки.Количество() Цикл
 врЗаголовок = "";
 Если СокрЛП(Строка(ТЗ.Колонки[Кол-1].Заголовок)) <> "" Тогда
 врЗаголовок = Строка(ТЗ.Колонки[Кол-1].Заголовок);
 Иначе
 врЗаголовок = Строка(ТЗ.Колонки[Кол-1].Имя)
 КонецЕсли;
 Таб.Область(2,Кол+1).Текст = врЗаголовок;
 Таб.Область(2,Кол+1).Шрифт = Новый Шрифт(,,Истина);// жирный
 Таб.Область(2,Кол+1).Обвести(ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния);
 врШир = ТЗ.Колонки[Кол-1].Ширина;
 Если врШир > 0 Тогда
 Таб.Область(2,Кол+1).ШиринаКолонки = врШир;
 КонецЕсли;
 КонецЦикла;
 i=0;

 Для Каждого Ном ИЗ ТЗ Цикл
 i=i+1;
 Таб.Область(i+2,1).Текст=Строка(i);
 Таб.Область(i+2,1).Обвести(Линия, Линия, Линия, Линия);
 Для Кол=1 По ТЗ.Колонки.Количество() Цикл
 Таб.Область(i+2,Кол+1).Текст=Строка(ТЗ[i-1][кол-1]);
 Таб.Область(i+2,Кол+1).Обвести(Линия, Линия, Линия, Линия);
 КонецЦикла;
 Если i/10=Цел(i/10) Тогда 
 Состояние(Заголовок+", печать: "+Строка(i));
 КонецЕсли;
 КонецЦикла; 
 Таб.Показать(Заголовок);
#КонецЕсли
КонецПроцедуры
Категория: Таблица Значений | Добавил: c1
Просмотров: 2453 | Загрузок: 0 | Рейтинг: 5.0/1

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar