Главная » Файлы » Программируем в 1С » 1С Разное

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Функция для получения курса валют банка Украины 1с 8.2
2012 Сентябрь 27, 13:42
Функция для получения курса валют банка Украины

В даном примере получим текущий курс валют  от Банка приват 24

Простое ришение иногда большой проблемы :)





Функция КурсНужнойВалюты()    
    
    ВыборкаВалюты = "EUR";
    АдресБУ = "https://privat24.privatbank.ua/p24/accountorder?oper=prp&exchange&    PUREXML&coursid=3";
    Файл = Новый ЧтениеXML;
    Файл.ОткрытьФайл(АдресБУ);
    
    
    Пока Файл.Прочитать() Цикл
        
        
        Если Файл.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            Если Файл.Имя = "exchangerate" Тогда
                
                Пока Файл.ПрочитатьАтрибут() Цикл
                    
                    Если  Файл.Имя = "ccy"  Тогда
                        
                        Если Файл.Значение = ВыборкаВалюты Тогда
                            
                            файл.СледующийАтрибут();
                            
                            Если файл.Значение = "UAH" Тогда
                                
                                файл.СледующийАтрибут();
                                
                                Если   файл.Имя = "buy" Тогда
                                    
                                    КурсВалют  = Файл.Значение;
                                    
                                        
                                    
                                    Сообщить(КурсВалют);

                                КонецЕсли;
                            КонецЕсли;
                        КонецЕсли;
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;    
    
    Файл.Закрыть();
    
КонецФункции

Категория: 1С Разное | Добавил: c1
Просмотров: 947 | Загрузок: 0 | Рейтинг: 0.0/0

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar