Главная » Файлы » Учебники по 1С » Примеры - Программисту

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Простой подсчет Суммы в ТЧ документа (Управляемые формы)
2012 Октябрь 29, 19:16
Простой подсчет Суммы в ТЧ документа (Управляемые формы) 1с 8.2

Оптимизируем (Практическое пособие разработчика Радченко М.Г)



// Общий модуль

Процедура РассчетатьСумму(СТЧ)Экспорт
  СТЧ.Сумма = СТЧ.Количество * СТЧ.Цена;
КонецПроцедуры




&НаКлиенте
Процедура МатериалыКоличествоПриИзменении(Элемент)
    СТЧ = Элементы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчетатьСумму(СТЧ);
КонецПроцедуры


&НаКлиенте
Процедура МатериалыЦенаПриИзменении(Элемент)
    МатериалыКоличествоПриИзменении(Элемент);       // НЕ ДУБЛИРУЕМ ПРОЦЕДУРУ ВВЕРХУ !
КонецПроцедуры





// стч - Табличная часть
Категория: Примеры - Программисту | Добавил: c1
Просмотров: 2883 | Загрузок: 0 | Рейтинг: 5.0/1

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar