Главная » Файлы » Программируем в 1С » 1С Разное

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Работа со строками в 1С 8.2
2013 Июль 15, 21:42

Работа со строками в 1С 8.2

Учимся работать со строками в 1С.

10 полезных функций для работы со строками.



1. ПустаяСтрока() - Проверяет строку на наличие значащих символов.

Синтаксис: ПустаяСтрока(<Строка>) 
Параметры: <Строка> (обязательный)

Пример:
--------------------------------------------------
Если НЕ ПустаяСтрока(МояСтрока) Тогда
Сообщить("Строка не пустая!")
КонецЕсли;
-------------------------------------------------



2. СокрЛП()  - Отсекает незначащие символы, стоящие слева от первого значащего символа в строке, и пробелы, стоящие справа от последнего значащего символа в строке.

Синтаксис: СокрЛП(<Строка>) 
Параметры: <Строка> (обязательный)

Пример:

---------------------------------------------------------------------
ЗначениеБезПробеловСлеваСправа = СокрЛП(МояСтрока);
--------------------------------------------------

3. СокрЛ() - Отсекает незначащие символы, стоящие слева от первого значащего символа в строке.

Синтаксис: СокрЛ(<Строка>) 
Параметры: <Строка> (обязательный)

Пример:

---------------------------------------------------------------------
ЗначениеБезПробеловСлева = СокрЛ(МояСтрока);
--------------------------------------------------

4.СокрП() - Отсекает незначащие символы, стоящие справа от последнего значащего символа в строке.

Синтаксис: СокрП(<Строка>) 
Параметры: <Строка> (обязательный)

Пример:

---------------------------------------------------------------------
ЗначениеБезПробеловСправа = СокрП(МояСтрока);
--------------------------------------------------

5.НРег() - Преобразует все символы строки в нижний регистр.

Синтаксис: НРег(<Строка>) 
Параметры: <Строка> (обязательный)

Пример:

---------------------------------------------------------------------
РезультатН = НРег(МояСтрока);
--------------------------------------------------

6.
ВРег() Преобразует все символы строки в верхний регистр.

Синтаксис: ВРег(<Строка>) 
Параметры: <Строка> (обязательный)

Пример:

---------------------------------------------------------------------
РезультатВ = ВРег(МояСтрока);
---------------------------------------------------------------------

7.Найти() - Позволяет найти в строке определенные символы.
Если строка найдена возвращается позиция первого символа.

Синтаксис Найти(<ИсходнаяСтрока,<ИскомыеСимволы>)
Параметры <ИскомыеСимволы> – искомые символы [строка]

Пример1:

---------------------------------------------------------------------
НашТекст = "Перевозка товаров быстро";
РезультатПоиска = Найти(НашТекст, "ы");

Если РезультатПоиска > 0 Тогда
Сообщить(РезультатПоиска);
// Вернет 20, первый символ 
КонецЕсли;

Пример2:

НашТекст = "Красный зеленый жёлтый синий";
Если Найти(НашТекст, "жёлтый") > 0 Тогда
Сообщить(Найти(НашТекст, "жёлтый"));
// результат: 17  Если строка найдена возвращается позиция   // первого найденного значения.
КонецЕсли;

---------------------------------------------------------------------


8.СтрЗаменить() -
Находит в исходной строке все вхождения подстроки поиска и заменяет ее на подстроку замены.

Параметры:

<Строка> (обязательный)

Тип: Строка. Исходная строка. 
<ПодстрокаПоиска> (обязательный)

Тип: Строка. Искомая подстрока. 
<ПодстрокаЗамены> (обязательный)

Пример:

---------------------------------------------------------------------
Результат = СтрЗаменить (МояСтрока, "+", "-");
---------------------------------------------------------------------


9.Лев() - Выбирает первые слева символы строки.

Синтаксис:

Лев(<Строка>, <ЧислоСимволов>) 
Параметры:<Строка> (обязательный)

Тип: Строка. Исходная строка. 
<ЧислоСимволов> (обязательный)

Пример:

---------------------------------------------------------------------
Рез = Лев(МояСтрока,4); // Первые 4 слева
---------------------------------------------------------------------

10.Прав() - Выбирает первые справа символы строки.

Синтаксис:

Прав(<Строка>, <ЧислоСимволов>) 
Параметры:<Строка> (обязательный)

Тип: Строка. Исходная строка. 
<ЧислоСимволов> (обязательный)

Пример:

---------------------------------------------------------------------
Рез = Прав(МояСтрока,4); // Первые 4 справа
---------------------------------------------------------------------





Чтоб лучше понять здесь, что и к чему, попробовать сразу на практике , сделал простенькую обработку со всеми этими встроенными функциями, можете скачать.

С Уважением Богдан.







Категория: 1С Разное | Добавил: c1
Просмотров: 5951 | Загрузок: 89 | Рейтинг: 0.0/0

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar