Главная » Файлы » Справка на Примерах 1С » Регистры расчета

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




v8.2 УП: Как очистить регистр расчета?!
2012 Июнь 01, 22:07

1C 8.2 УП Как очистить регистр расчета?


Запрос=Новый Запрос;
 Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
 | УправленческиеНачисления.Регистратор
 |ИЗ
 | РегистрРасчета.УправленческиеНачисления КАК УправленческиеНачисления";
 РезультатЗапроса = Запрос.Выполнить();
 Выборка = РезультатЗапроса.Выбрать();
 Кол=0;
 БылиОшибки=Ложь;
 
 //РегистрыНакопления.ЗаказыМагазинов.УстановитьИспользованиеИтогов(Ложь);
 
 Пока Выборка.Следующий() цикл
 //ОбработкаПрерыванийПользователя();
 
 Набор = РегистрыРасчета.УправленческиеНачисления.СоздатьНаборЗаписей();
 Набор.Отбор.Регистратор.Значение = Выборка.Регистратор;
 Попытка
 Набор.Записать();
 Исключение
 БылиОшибки=Истина;
 КонецПопытки;
 Кол=Кол+1;
 ЕСЛИ Кол%100=0 Тогда
 Сообщить("Отработано "+Кол+" документов из "+Выборка.Количество());
 КонецЕсли;
 КонецЦикла;
 //РегистрыНакопления.ЗаказыМагазинов.УстановитьИспользованиеИтогов(Истина);
 
 
 Если БылиОшибки Тогда
 Предупреждение("Обработка завершена. Регистр очищен не до конца!!!");
 КонецЕсли; 



Категория: Регистры расчета | Добавил: c1
Просмотров: 1428 | Загрузок: 0 | Рейтинг: 0.0/0

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar