Главная » Файлы » Уроки "1С ОТ а ДО Я" » Уроки "1С ОТ а ДО Я"

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Урок четвертый ( Раздел №1) "Циклы в 1С"
2012 Декабрь 22, 19:44
Урок четвертый ( Раздел №1) "Циклы в 1С"

Здравствуйте !
 
Начинаем четвертый  урок !

  Мы продолжим, сегодня изучение  Справочников , а также познакомимся из  циклами в 1С !  
И так «Справочники» и что еще нам нужно знать:
    
1.   Реквизиты и табличная часть Справочника
2.   Иерархия в справочниках
3.   «Владельцы» в справочниках !


Что такое реквизиты справочника ?

  Реквизиты у справочника могут быть конечно самые разные но есть и «Базовые» , эти реквизиты создаются автоматически при создании  справочника - «Код» и «Наименование»



«Код» - служит для соблюдения уникальности записей в справочнике так как наименования у нас могут быть одинаковы.


«Наименование» - стандартный реквизит в который записываются собственно  наименования элементов !


Остальные реквизиты создаются уже из потребностей , это могут быть например: «Цена» «Единицы измерения», «Полное Наименование» и тд !



Табличная часть справочника -  Каждый справочник может иметь свою табличную часть. Перейдите на вкладку «Данные» в справочнике и внизу вы увидите «Табличные части»

Как правило табличную часть справочника, создают для записи в нее большого количества данных !   Например это может быть разные свойства какого то  товара , номенклатуры, и  удобней всего хранить такую информацию будет в табличных частях справочника !

Иерархия в справочниках может быть - «Иерархия групп и элементов»  или «Иерархия элементов» Для этого отметим чекбокс «Иерархический справочник» Что это значит , это значит что в первом варианте как группы так и элементы могут быть иерархическими а во втором только элементы.

«Владельцы» в справочниках  - Каждый из справочников может быть подчиненным , то есть иметь «владельца».


Для чего создают такой справочник ?  для того чтоб связать элементы справочников, например:

Между справочниками может быть установлено отношение подчиненности. В этом случае каждый элемент подчиненного справочника будет связан с одним из элементов справочника-владельца. Часто можно сказать, что элементы одного справочника принадлежат элементам другого.

Например, в системе может быть справочник РасчетныеСчета, тогда его можно сделать подчиненным справочнику Контрагенты. Это означает, что «Контрагент владеет расчетными счетами, а расчетные счета принадлежат контрагенту»

Пример выше я нашел на сайте:

 (Из сайта: http://ops.org.ua/P3/PodSprav.php )

Фактически в десятку все придельно понятно !


Циклы в 1С

  Циклы с известным количеством повторений


Цикл – это конструкция, которая повторяет выполнение строк находящихся в теле цикла, количество повторений зависит от результата выполнения условий в начале цикла.

  Кстати повторение еще называют Итератором если вдруг встретите такое слово то не пугайтесь, это просто повторитель !


----------------------------------------------------------------------
Для Счетчик = 1 По 5 Цикл   
 //Тело цикла
 КонецЦикла;

----------------------------------------------------------------------

« Для ...  По  ... Цикл » - повторяет количество циклов с начального значения счетчика до конечного указанного значения, в данном случаи , пока не пройдет 5 повторений

Такой тип используется, когда известно количество повторений. 

 Давайте посмотрим на примере:


--------------------------------------------
Для Месец = 1 По 12 Цикл
 Сообщить(Месец);
 КонецЦикла;

--------------------------------------------


Посмотрите что получиться ! 
 Если бы не цикл нам пришлось бы выводить каждую строку отдельно!   То есть писать 12 раз каждую строку на вывод !

  А приставьте себе цикл « По 1000 » :)



Циклы с не известным количеством повторений



------------------------------------------------------------------

Для Каждого ТабЧ из ТЧ Цикл
 //Тело цикла
 КонецЦикла;

------------------------------------------------------------------

«Для Каждого … Из … Цикл» перебирает коллекцию с первого по последний элемент. Записывая в переменную ( «ТабЧ» ) значение элемента. Для примера, это может быть табличная часть документа где нужно получить все ее записи для вывода !

----------------------------------------------------
Пока Выборка.Следующий() Цикл
     //Тело цикла
 КонецЦикла;

----------------------------------------------------

«Пока … Цикл» - выполняется пока вычисляемое значение равно Истина. Может использоваться в случаях, когда переменные для вычисления выражения меняются в теле цикла либо, если перебирается коллекция и у нее есть соответствующий метод возвращающий булево, который вызывается в начале цикла.


В данном примере это может быть выборка из «запроса» и пока условие не «Истина» цикл продолжает работать.

Когда выборка дойдет до конца то  Выборка.Следующий() получит значение «Ложь» и Цикл соответственно завершится ! Потому что его условие работать пока  Выборка.Следующий() =  «Истина»


На этом четвертый урок закончен ! 

 В следующим уроке ... 

1.     Интерфейсы
2.     Роли
3.     Пользователи



Категория: Уроки "1С ОТ а ДО Я" | Добавил: c1
Просмотров: 4071 | Загрузок: 0 | Рейтинг: 5.0/1

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar