Главная » Файлы » Уроки "1С ОТ а ДО Я" » Уроки "1С ОТ а ДО Я"

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Урок второй ( Раздел №1) “Справочники”
2012 Декабрь 09, 13:03

Урок второй ( Раздел №1)   "Справочники”


В этом уроке мы освоим...
1. Операторы в 1С
2. Что такое Справочники , и как их используют.
3 Функции в 1С
----------------------------------------------------------------------------------------------------------

И так давайте познакомимся с основными операторами в 1С Операторы:   " Если ”  ,   "Тогда”,      "Иначе” ,   "ИначеЕсли” ,   "КонецЕсли”

Давайте напишем небольшое условие   используя операторы,
  а затем я объясню все подробно. 

Опять таки вернемся к нашей обработке из прошлого урока и «за комментируем» наш код

«за комментируем» значит сначала в строке ставим  «//» два слеша , тогда код не будет читаться программой !
Это позволит не удалять то что мы писали раньше.
Кстати если хотите, то вы можете создать  свои обработки ,а не использоваться каждый раз одну и ту же !

(Кстати забыл сказать ,что оператор "Процедура” и "КонецПроцедуры”  обозначают секцию исходного кода между ними ,
тесть код  будет читаться между этими операторами впрочем, как и в функциях но об этом по позже )

Процедура КнопкаВыполнитьНажатие(Кнопка) 
  A = 1;  
 Если  A = 0 Тогда    
   В = 5 
  Иначе     
  В = 2  
 КонецЕсли;  
 Сообщить(В);
КонецПроцедуры



Начинается условие с открытия оператора "Если” и заканчивается  оператором "КонецЕсли” - который и закрывает условие.

"A”
это переменная , мы можем присвоить ей любое значение в нашем случаи присвоено "1”
Дальше  мы проверяем наше условие , если  "А = 0”
тогда выполняем какое то действие  иначе

Делаем что нибудь другое ,
 в нашем примере мы присвоили значение B = "5”

Иначе мы присвоим значение B =  "2”

Затем мы закрываем условие и выводим результат в "Сообщить”
То есть у нас выполняется либо первый блок кода либо же второй, в зависимости от условия !

Попробуйте поэкспериментируйте  !

Справочники в 1С....

 Справочник  в 1С  - это объект конфигурации что позволяет записывать и хранить значения .

Например вместо того чтоб постоянно присваивать значение мы можем его записать в справочник  ,
а потом при нужде так сказать это значение получить !
Например у нас есть фирма в которой работает много сотрудников, мы же не будим  их всех в код модуля запихивать :) 
так как оперировать таким набором данных будет крайне сложно и неудобно !

Собственно потому и появился справочник !
Он как шаблон , готов принять любой вид данных для хранения
Мы же программно создаем не сам справочник а только его шаблон (Конструкцию).
Я бы даже сравнил справочник из каким нибудь журналом который мы завели для чего либо .
Сам по себе созданный журнал пустой и не нужный
НО если сделать разметку сложить как то красиво листы,
 в зависимости от наших нужд то это будет мощный инструмент  !

Так и в 1С Справочники, это самый нужный инструмент и основной объект  при создании практически любой системы учета !

Давайте создадим такой справочник  и назовем его "Сотрудники”

Чтоб не делать массу скриншотов я записал маленький ролик как это проделать смотрим





Поздравляю вы создали справочник Ура !

Давайте сохраним ,запустим нашу конфигурацию и сделаем несколько записей в наш только что созданный справочник.!


Как видите мы смогли записать  сотрудников в наш справочник "Сотрудники”
и теперь в любой момент мы можем к нему обратится  отредактировать запись , заменить сотрудника !


 и это  не прибегая к коду. :)
Ну что ж,  вернемся к нашим  "Баранам”  то есть операторам :)
 Сей час мы еще немного с ними поработаем,
для того чтоб вы их получше усвоили,
  правда с одним НО ,


мы будем работать с ними, в теле функций !

Функции …..


Что такое функция в 1С ?

  это тоже что и Процедура только вот Функция умеет возвращать результат !Давайте напишем простую функцию ,посмотрим на примере !

Функция ОбчислитьЗнач();
    А = 5;
   Б = 2;  
 Возврат(А+Б);
КонецФункции



 Результат который она нам вернет Сообщим в Процедуре "КнопкаВыполнитьНажатие(Кнопка)”

То есть так

 Процедура КнопкаВыполнитьНажатие(Кнопка)    
 Сообщить(ОбчислитьЗнач()); 
КонецПроцедуры  


 Сообщить(ОбчислитьЗнач());  -  Как в процедуре так и в функции мы можем передавать параметры (об этом я еще расскажу в следующих уроках ) но так как функция у нас параметров не имеет то мы пишем пустые скобки () !

 и передаем ее результат в функцию "Сообщить”. на вывод ! 

  Получается что результат работы функции выводит другая процедура !
В основном так используют функции и при исполнении повседневных задач программиста.

Давайте напишем еще несколько функций


-------------------------------------------------------------------------------------------------
Функция ОбчислитьЗнач2(); 
  А = 5;  
 Б = 2;
   С = А - Б;
   Возврат(С);
КонецФункции

-----------------------------------------------------------------------
Функция ОбчислитьЗнач3();  
 Стр = "Результат функции:";
    А = 150;  
 Число = (А/100*20);
   Б = 2; 
  С = Число - Б;
   Возврат(""+Стр + С);
КонецФункции


---------------------------------------------------------------------------------------------------

Думаю у вас есть вопрос почему я поставил  ("”     +Стр + С)  две кавычки   в последний функции ?
Чтоб выполнить операцию сложения  Строкового типа И Числового типа

 Но об этом в следующим уроке !

В следующим уроке ...

1.    Типы Данных в 1С
2.    Функции и Процедуры  (Продолжение)
3. Программная запись, редактирование и удаление ,Справочников !
Категория: Уроки "1С ОТ а ДО Я" | Добавил: c1
Просмотров: 2467 | Загрузок: 0 | Рейтинг: 5.0/1

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar