Главная » Статьи » "1С" Програмирование

Скачивать материалы с сайта, могут только зарегистрированные пользователи.
Для регистрации заполните два поля ниже!

Через минуту Вы получите "Гостевой доступ"




Правильная выгрузка регламентированных отчетов в формате Excel
Правильная выгрузка регламентированных отчетов в формате Excel
 
 
При формировании регламентированных отчетов и сохранении их в формате Excel (с применением пункта меню в 1С - "Сохранить копию"), платформа не умеет правильно это делать. Т.е. если выбрать любой из форматов, то либо рвутся таблицы (ширина, высота) либо неверно передается форматирование ячеек.
Например в балансе (который делаем в тысячах) при выгрузке в ячейки попадают "полные значения", т.е. в ячейке значение 192345,56 - баланс формируется в тысячах и видим мы в ячейке: 192 , но при сохранении в Excel в ячейки попадает 192345,56.
Данный пример описывает способ обхода этой проблемы. Главбухи будут довольны ;-)
Для платформы 8.*
 
1. Находим обработку "ОбщиеОбъектыРегламентированнойОтчетности"
2. Добавляем на форму "ПечатьРегламентированныхОтчетов" кнопку "Сохранить в Excel"
3. На кнопку вешаем эту процедуру:

Процедура ОсновныеДействияФормыСохранитьВExcel(Кнопка) 
  ТабДок = Новый ТабличныйДокумент;
  ТабДок.Вывести(ЭлементыФормы.ИтоговаяТаблица);
  Для Каждого Область Из ТабДок.Области
Цикл
     Попытка
       СтароеЗначение = Область.Значение;
       Значение = Область.Текст;
       Область.Формат = Неопределено;
       Область.Значение = Значение;
     
Исключение
       
// нельзя читать
    КонецПопытки;
КонецЦикла;
 Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
 Диалог.Фильтр = "Файл Excel(*.xls)|*.xls";
 Если Диалог.Выбрать(
) Тогда
    ТабДок.Записать(Диалог.ПолноеИмяФайла,ТипФайлаТабличногоДокумента.XLS);
КонецЕсли;
КонецПроцедуры


Все.
 
Вариант 2 от Fuego http://infostart.ru/profile/24230/  с использованием программы "1С: Работа с файлами" http://v8.1c.ru/metod/fileworkshop.htm

"Из 1С-ки сохраняем в обычном формате табличного документа (MXL), открываем этот файл в "1С:Работа с файлами", и сохраняем копию в формате "XLS". Даже группировки и фиксация областей сохраняться."
 

статья с сайта: www.infostart.ru

Категория: "1С" Програмирование | Добавил: c1 (2009 Февраль 21)
Просмотров: 2453 | Рейтинг: 0.0/0

Выразить благодарность - Поделиться с друзьями!

 

Здесь все о технической стороне 1С!

 

Узнай, как правильно администрировать 1С Предприятие
Регистрируйся на бесплатный 7-ми дневный курс сейчас:

Ваш E-Mail в безопасности



Всего комментариев: 0
avatar